О программе

 Top Next

Название программы

«Уравнения нелинейной регрессии, тренды двумерные функционально-факторные с самоопределяющимися параметрами и повышенной достоверностью (Тренды ФСП-1)»

Правообладатель

© 2011 Учреждение Российской академии наук Институт горного дела Уральского отделения РАН (ИГД УрО РАН)

Все права защищены.

Внесено в Реестр РФ программ для ЭВМ.

Свидетельство о государственной регистрации № 2011616230.

Сведения об авторах

Антонов Владимир Александрович - создание методологии построения и алгоритмов расчета уравнений регрессии, трендов ФСП-1, дизайна программы.

Яковлев Михаил Викторович - создание структуры, алгоритма и дизайна программы.

Ссылка в литературе на программу

Антонов В.А. Уравнения нелинейной регрессии, тренды двумерные функционально-факторные с самоопределяющимися параметрами и повышенной достоверностью (Тренды ФСП-1): программа для ЭВМ, РФ; регистр. номер 2011616230 / В.А. Антонов, М.В. Яковлев; ИГД УрО РАН.- Екатеринбург, 2011.


Назначение и область применения программы

 Top Previous Next

Назначение программы

Программа предназначена для расчета (по случайно распределенным значениям зависимой величины) и графического построения двумерных функционально-факторных уравнений нелинейной регрессии, трендов, обладающих повышенной достоверностью, представленных в виде полиномов функций, параметры которых (показатели, коэффициенты, основания и т. д.) самоопределяются в процессе расчета.

Область применения программы

Программа применяется в регрессионном анализе зависимой величины в случаях возможного математического выражения искомых уравнений её нелинейной регрессии, трендов полиномами одинаковых или разных функций. Ее можно применять в областях промышленности, науки и техники, где в качестве зависимой величины могут рассматриваться величины математические и физические, а также другие параметры и показатели, например, социологические, технические, экономические. Применение программы позволяет решить следующие задачи регрессии.

· Установить, дать истолкование, объяснить математически закономерность, по которой с некоторым случайным отклонением распределены значения зависимой величины, полученные в экспериментах.
· Создать математическую регрессионную модель исследуемых объектов или процессов.
· Определить характерные параметры (экстремумы, особые точки, асимптоты, пересечения с осями координат) отображаемых объектов или процессов.
· Предсказать значения зависимой величины (дать прогноз) в областях интерполяции и экстраполяции.
· Управлять объектом или технологическим процессом по уравнению регрессии.


Принцип построения уравнений регрессии, трендов ФСП

Уравнения нелинейной регрессии, тренды ФСП строятся по функционально-факторному принципу, согласно которому входящие в них функции задаются в общем виде и рассматриваются как математически выраженные факторы влияния природных или каких-либо иных процессов на искомую регрессию. Функции содержат в себе параметры таким сложным образом, что уравнения по признаку их оценки не сводятся к линейному виду. Для построения регрессии пользователю не нужно априори задавать параметры, содержащиеся в функциях уравнений, даже в нулевом приближении. Итоговые значения этих параметров, устанавливающие окончательный и конкретный вид факторных функций, их отдельные черты по степени возрастания или убывания, вогнутости или выпуклости, самоопределяются, т.е. объективно рассчитываются как оптимальные в области рациональных чисел (дробных, положительных и отрицательных) самой программой. Критерием оптимизации является достижение наибольшего коэффициента детерминации R2 уравнений. Так как их вид выбирается по характеру факторных функций, описывающих предполагаемое воздействие на регрессию природных процессов, и параметры этих функций самоопределяются с учетом особенностей распределения заданных узловых точек, то установленные с их применением уравнения ФСП распространяются в широких интервалах интерполяции и экстраполяции со значительно большей достоверностью по сравнению с известными уравнениями, в которых функции и функциональные параметры, например, показатели степени, назначаются искусственно.

Факторы влияния выражаются математически функциями Z(х, ξ), где х – детерминированный аргумент; ξ – самоопределяющиеся параметры. Например, в случае выражения фактора степенной функцией (ξ=μ, μ – показатель степени) имеем Z=X μ, а в случае его выражения показательной функцией (ξ=β, β – коэффициент в показателе степени) - Z = а βx, где а – основание.

Уравнения регрессии, тренды формируются с учетом аддитивного и мультипликативного взаимодействия факторов влияния. При аддитивном взаимодействии наличие каждого интервала регрессии, в пределах которого при частном изменении аргумента ее величина Y изменяется монотонно (возрастает или убывает), обусловлено влиянием какого-либо фактора. Влияние нескольких факторов отображается в математической формуле уравнения суммой соответствующих функциональных членов Z. При мультипликативном взаимодействии функциональных факторов сочетание двух интервалов противоположной монотонности тренда в области экстремума (например, его возрастания и убывания) отображается в формуле уравнения произведением разных функций Z1Z2. Формула уравнения регрессии, тренда представляется в следующем виде

где Y – регрессия; j – номер интервала монотонности регрессии, учтенного аддитивно; ν – номер экстремума в регрессии, учтенного мультипликативно; B, Aj , Aν – коэффициенты.

Оптимальные значения параметров ξ рассчитываются на основе совместного применения метода наименьших квадратов (МНК) и специально разработанного в Институте горного дела УрО РАН нового численного метода оптимизации – метода приближений параболической вершины (МППВ).

Суть МППВ (метода В.А. Антонова) состоит в многократно повторяющейся и уточняющейся аппроксимации экстремальной области m-мерной функции R2(ξ m) ≡ R2(ξ1, ξ2, ξ 3 …ξ m) также m-мерной параболической функцией, имеющей единственный максимум, условно названный вершиной. В k-приближении параболическая функция Pk(ξ m) представляется в виде

где Сk, Сj1k, Сj2k – коэффициенты. Аппроксимацию проводят по опорным точкам, принадлежащим функции R2(ξm), для которых выполняются неравенства коэффициентов Сj2k< 0. В процессе приближений опорные точки с наименьшим значением R2(ξ m) с учетом необходимой коррекции Сj2k<0 заменяются вновь образованными опорными точками с параметрами ξ1вk, ξ2вk, … ξmвk , рассчитанными по вершине параболической функции. В результате аппроксимации осуществляется последовательное приближение вершинной точки параболической функции к точке максимума коэффициента детерминации тренда. Таким образом, рассчитывается с заданной сколь угодно малой погрешностью совокупность функциональных параметров уравнения регрессии, тренда ξ 1, ξ 2, ξ 3 …ξm , при которой коэффициент его детерминации R2 наибольший из всех возможных, оцениваемых МНК.

В соответствии с принятой концепцией построения уравнения регрессии, тренды ФСП-1 классифицированы с разделением на виды и типы по признакам названия вовлеченных в регрессию математических функций и вида их взаимодействия (А – аддитивный, М – мультипликативный), количества независимых аргументов, количества самоопределяющихся функциональных параметров при каждом аргументе в аддитивном факторе (ξ1, ξ2, …) , а также в мультипликативном факторе (ξм1, ξм2, …).

Виды и типы уравнений нелинейной регрессии, трендов ФСП-1, проводимые данной программой, представлены в таблице 1.

Таблица 1 - Двумерные Уравнения регрессии, тренды ФСП-1
Кол-во экстремумов вдоль оси Х | Тип уравнения регрессии (самоопреде-ляющиеся параметры) | Формула уравнения регрессии, тренда | Характерный график
Полиномные степенные с самоопределяющимися показателями степени (ПС СПС), X > 0
0 | А-Х(μ) |  |
1 | А-Х(μ1, μ2) |  |
2 | А-Х(μ1, μ2, μ3) |  |
 | «Ориентирован-ный» | Выбирается автоматически из следующих типов А-Х(μ), либо А-Х(μ1, μ2), либо А-Х(μ1, μ2, μ3)
Полиномные показательные с самоопределяющимися коэффициентами в показателях степени (ПП СК)
0 | А-Х(β) |  |
0, 1 | А-Х(β1, β2) |  |
Полиномный показательный и линейный степенной с самоопределяющимся коэффициентом в показателе степени (ППЛС СК)
0, 1 | А-Х(β, μ =1) |  |
Нормального распределения с самоопределяющимися коэффициентами (НР СК), σ> 0
1 | М-Х(, σ) |  |
Полиномный показательный и нормально распределенный с самоопределяющимися коэффициентами (ППНР СК), σ > 0
1 | АМ-Х(β, , σ) |  |
Полиномные ассиметричного распределения с самоопределяющимися основаниями и показателями степени (ПАР СП), X > 0, а >1, μ > 0
1 | М-X( а, μ) |  |
1 | М-X( а, μ, x > x0) |  |
1 | М-X(а, μ, x < x0) |  |
1, 2 | АМ-X(а1, а2, μ1, μ2, х>х01, х>х02) |  |
1, 2 | АМ-X(а1, а2, μ1, μ2, х <х01, х <х02) |  |
1, 2 | АМ-X(а1, а2, μ1, μ2, х01< х < х02) |  |
Полиномные квазиступенчатые с самоопределяющимися параметрами (ПКС СП) Г – горизонтальные, П – параллельные .
0 | А-X(х0, β) Г |  |
0, 2 | А-X(х0, β) П |  |
1, 2 | А-X(х0, β) |  |
ПолиномныЙ СИНУС (ПSin)
Множество | А-X(ω, φ) |  |
ПолиномныЙ Амплитудно-зависимый СИНУС (пАSin)
Множество | АM-X(ω, φ, βа) |  |
ПолиномныЙ показательный с СИНУСом (ппSin)
Множество | А-X(ω, φ, β) |  |
ПолиномныЙ показательный с амплитудно-зависимым СИНУСом (ппаSin)
Множество | АM-X(ω, φ, βп,βа) |  |

Достоверность интерполяции в широких интервалах и экстраполяции уравнениями регрессии, трендами ФСП-1 значительно выше по сравнению с известными уравнениями, в которых параметры, входящие в выбранные функции, искусственно подобраны априори заданными какими-либо числами. Тем не менее, тип тренда ФСП-1 может быть выбран однозначно лишь по заранее известным особенностям и свойствам искомой регрессионной зависимости. Часто таких сведений нет. Однако, по имеющимся данным об относительной погрешности тех средств или методов, с применением которых получены (косвенно рассчитаны или непосредственно измерены) исходные значения зависимой величины, можно рассчитать коэффициент заданной детерминации Rз2. Затем выбирается как наиболее достоверный тренд такого вида и типа, коэффициент детерминации которого наиболее близок по значению к коэффициенту заданной детерминации.

В программе ФСП-1 при выборе степенных уравнений регрессии, трендов ПС СПС есть возможность автоматически определить его тип, ориентированный на погрешность исходных значений зависимой величины. В опции «ПС СПС ориентированный» по введенной относительной погрешности δyi рассчитывается коэффициент заданной детерминации Rз2

и программой выбирается как наиболее достоверный такой тип тренда ПС СПС, при котором абсолютная разность между коэффициентами Rз2 и R2 минимальная. Относительная погрешность задается в интервале от нуля до максимально допустимого значения, ограниченного неравенством Rз2 > 0.

Уравнения ФСП (формулы, графики, коэффициент детерминации, оценка адекватности) распространяются в областях интерполяции и экстраполяции при условии их однородности (одинаковых свойств) с заданными узловыми точками, по которым строится регрессия. Это означает, что в областях, так же, как в узловых точках, действуют факторы, функционально учтенные в уравнениях, и не предполагается появление других, вновь возникших, факторов. Таким же образом, при удалении от узловых точек в областях сохраняются другие свойства пространства, косвенно влияющие на регрессию. Новые свойства пространства в этих областях возникать не должны. Внешние границы регрессии устанавливаются там, где по теоретическим соображениям прекращается действие хотя бы одного из учтенных факторов. Это может произойти на краю зоны локального распространения факторов, при появлении обусловленного чем-либо граничного значения зависимой величины или факторной функции, смене их алгебраического знака и т. д.


Режимы и параметры построения уравнений регрессии, трендов

Программа рассчитывает и строит следующие уравнения регрессии, тренды:

· линейный;
· степенной;
· показательный;
· вид ПС СПС, типы: А-Х(μ), А-Х(μ1, μ2), А-Х(μ1, μ2, μ3), ориентированный;
· вид ПП СК, типы: А-Х(β), А-Х(β1, β2 );
· вид ППЛС СК, тип А-Х(β, μ =1);
· вид НР СК, тип М-Х(м, σм);
· вид ППНР СК, тип АМ-Х(β, м, σм);
· вид ПАР СП, типы: М-X(а, μ), М-X( а, μ, x > x0), М-X( а, μ, x < x0), АМ-X(а1, а2, μ1, μ2, х> х01, х > х02), АМ-X(а1, а2, μ1, μ2, х < х01, х < х02), АМ-X(а1, а2, μ1, μ2, х01< х < х02);
· вид ПКС СП, типы: А-X(х0, β)Г, А-X(х0, β)П, А-X(х0, β);
· вид ПSin, тип: А-X(ω, φ);
· вид ПАSin, тип: АМ-X(ω, φ, βа);
· вид ППSin, тип: А-X(ω, φ, βп);
· вид ППАSin, тип: АМ-X(ω, φ, βа , βп).

Уравнения регрессии, тренды ПП СК А-Х(β), А-Х(β1, β2); ППЛС СК А-Х(β, μ =1); ПАР СП М-X(а, μ), М-X( а, μ, x < x0), АМ-X(а1, а2, μ1, μ2, х < х01, х < х02) строятся в двух следующих режимах:

· точка пересечения линии тренда с вертикальной осью координат Y при значении X = 0 не задана;
· точка пересечения линии тренда с вертикальной осью координат Y при значении X = 0 задана.

Относительная погрешность расчета параметров функций от 0,1 до 0,0001.

Ограничение числа итераций при определении одного параметра в одном цикле вычислений от 500 до 50000.

Ограничение числа циклов вычислений от 1000 до 15000.

Число десятичных знаков после запятой в формуле тренда от 0 до 15.

Десятичный разделитель сохраняется в виде точки или запятой.

Знак аргумента:

· в трендах ПС СПС, ПАР СП аргумент Х положительный;
· в трендах ПП СК, ППЛС СК, НР СК, ППНР СК, ПКС СП, ПSin, ПАSin, ППSin, ППАSin аргумент Х отрицательный и положительный.

Минимальный диапазон отсчета по шкале абсцисс Х от 0 до 10-9.

Максимальный диапазон отсчета по шкале абсцисс Х от 0 до 1012.

Знак трендов вида ПС СПС, ПП СК, ППЛС СК, ПАР СП, ППНР СК, ПКС СП, ПSin, ПАSin, ППSin, ППАSin положительный и отрицательный.

Знак трендов вида НР СК либо целиком положительный, либо целиком отрицательный.

Минимальные диапазоны отсчета по шкале ординат Y от -10-9 до 0, от 0 до 10-9.

Максимальные диапазоны отсчета по шкале ординат Y от -1012 до 0, от 0 до 1012.

Уравнения регрессии, тренды представляются в виде математических текстовых и (или) графических формул, а также в виде графиков.

Об окончании вычислений

Вычисление формулы уравнения регрессии прекращается при достижении требуемой точности (относительная погрешность расчета), либо при достижении максимального числа итераций для типов трендов, в которых определяется один параметр, либо при достижении максимального числа циклов для типов трендов, в которых определяются более одного параметра.


Интерфейс программы

В программе задействовано несколько окон:

· Окно построения трендов
· Окно выбора параметров
· Окно выбора типа тренда
· Окно задания погрешности данных
· Окно работы с проектами
· Окно подписей к графикам


Окно построения трендов

Интерфейс окна построения трендов состоит из главного меню; кнопок для часто используемых функций; панели для ввода исходных данных с клавиатуры или с помощью мыши, а также для выбора типа тренда; панели для настройки внешнего вида графиков; поля для вывода уравнений трендов; поля для отображения графиков исходных данных и полученных трендов.

Назначение органов управления опциями программы представлено ниже :

В главном меню есть пункты :

Открыть - чтение исходных данных из

1) текстового файла (.txt) , где данные расположены построчно в виде пары чисел в каждой строке, первое число - значение независимой величины, второе число - соответствующее значение зависимой величины. Наличие какого-либо количества пробелов и знаков табуляции до, после или между парой чисел в каждой строке значения не имеет, лишь бы эти числа были разделены хотя бы одним пробелом либо знаком табуляции;

2) файла Microsoft Excel (.xls) , где данные могут располагаться горизонтально, в 2 строки и не менее 3-х столбцов, или вертикально, в 2 столбца , не менее 3-х строк. Первое значение независимой величины должно располагаться в ячейке А1 электронной таблицы. Смежные с набором пары данных ячейки должны быть пусты.

3) файла проекта (.prj) , в котором хранятся не только исходные данные для нескольких трендов, но и формулы трендов, данные для рисования графиков трендов, свойства, атрибуты и оформление этих графиков. По сути, это текстовый файл, который редактировать в текстовом редакторе можно только в том случае, если точно знаешь, что делаешь.

Пункту меню Открыть соответствует кнопка [image] .

Сохранить данные - запись исходных данных в

1) текстовый файл (.txt) , где данные будут расположены в 2 столбца, десятичный разделитель для чисел - "точка", "запятая" или принятый в операционной системе по умолчанию - выбирается в панели, вызываемой выбором пункта главного меню "Параметры";

2) файл Microsoft Excel (.xls) , где данные будут располагаться горизонтально в 2 строки, или вертикально в 2 столбца, в зависимости от настроек в панели, вызываемой выбором пункта главного меню "Параметры".

Пункту меню Сохранить данные соответствует кнопка [image] .

Сохранить график - запись графика в файл формата Bitmap (.bmp) .

Вставить данные - чтение исходных данных из буфера обмена, при этом данные могут располагаться горизонтально, в 2 строки и не менее 3-х столбцов, или вертикально, в 2 столбца , не менее 3-х строк.

Пункту меню Вставить данные соответствует кнопка [image] .

Копировать текстовую формулу тренда в буфер обмена - для использования в программах сторонних производителей.

Копировать графическую формулу тренда в буфер обмена - для использования в программах сторонних производителей.

Копировать график в буфер обмена - для использования в программах сторонних производителей.

Пункту меню Копировать график в буфер обмена соответствует кнопка [image] .

Экспорт в Excel - вызов программы Microsoft Excel, размещение в новой книге листа с исходными данными, расположенными горизонтально в 2 строки, или вертикально в 2 столбца, и диаграммы с трендом на этом же листе или на отдельном листе - в зависимости от настроек в окне, вызываемом выбором пункта главного меню "Параметры".

Печать графика - по умолчанию формат листа бумаги А4 альбомной ориентации.

Пункту меню Печать графика соответствует кнопка [image] .

Параметры - вызов панели управления настройками программы.

Выход - завершение работы программы.

Вид - позволяет изменить внешний вид ("скин") программы, наличие или отсутствие формулы тренда и координатной сетки на графике, а также вызвать окно подписей к графику.

Основные кнопки :

- соответствует пункту меню Открыть

- соответствует пункту меню Сохранить данные

- соответствует пункту меню Копировать график в буфер обмена

- соответствует пункту меню Вставить данные

- соответствует пункту меню Печать графика

- кнопка "Пуск" служит для запуска вычисления формулы тренда

- кнопки навигации по страницам с графиками вычисленных трендов

Кнопки для ввода данных с помощью мыши :

- а) для включения режима ввода исходных данных в таблицу с помощью мыши

б) для отмены последней введённой точки

в) для повторного ввода отменённой точки или ввода новой точки в таблицу исходных данных

г) для очистки таблицы исходных данных

Кнопки для работы с данными открытого листа MS Excel :

- служит для импорта данных из рабочего листа MS Excel , при этом данные, расположенные в 2 ряда или в 2 столбца, должны быть выделены

- после построения тренда для импортированных из рабочего листа MS Excel данных , полученный тренд передаётся в этот лист

Кнопки включения / выключения отображения трендов:

- тренд отображается

- тренд не отображается

Панель выбора предельных значений и коэффициентов масштабирования по осям :

Интуитивно понятна.

Следует только иметь в виду, что от выбора коэффициента масштабирования (10n) зависит точность ввода исходных данных с помощью компьютерной мыши. Например, если пределы шкалы по X от -3x10 до 3x10 , то введённая точка может иметь значение 11.9 , а если пределы шкалы по X от -30 до 30, то введённая точка может иметь значение 11.89 .


Окно выбора параметров

Окно выбора параметров позволяет изменять некоторые характеристики при расчёте тренда.


Окно выбора типа тренда

Окно выбора типа трендов содержит 21 кнопку с формулами уравнения регрессии. При наведении курсора на кнопку появляется характерный вид кривой для этого типа тренда. На рисунке ниже курсор наведён на кнопку выбора тренда типа ПАР СП X(a1, a2, μ1, μ2, х > х01, х > х02):


Окно задания погрешности данных

Окно появляется при выборе типа тренда "ПС СПС ориентированный" и нажатии кнопки [image] .

Вы можете задать относительную погрешность δyi , одинаковую для всех исходных точек. Тогда установите щелчком мыши на световом индикаторе зеленый цвет и введите значение погрешности в верхнем окошке. После нажатия кнопки с галочкой это значение погрешности передается во все ячейки нижней строки δyi таблицы.

Для задания погрешности δyi отдельно для каждой исходной точки установите на световом индикаторе красный цвет и введите в ячейки нижней строки δyi таблицы соответствующие значения погрешности.

В обоих случаях после нажатия кнопки с галочкой будет подсчитан и отобразится заданный коэффициент детерминации R2.


Окно работы с проектами

Окно работы с проектами появляется при двойном клике мышкой по графику в окне построения трендов, либо при открытии файлов проекта (.prj).

Интерфейс окна работы с проектами включает в себя сообщение о размерах графика в пикселях, номере графика в проекте и кнопки управления:


Окно подписей к графикам

Интерфейс окна подписей к графикам приведён на рисунке:


Порядок ввода данных и построения уравнений регрессии, трендов

Ввод исходных данных может производиться несколькими способами:

1) Вручную - задав необходимое количество точек с координатами X,Y и введя эти координаты с клавиатуры компьютера в таблицу исходных данных;

2) С помощью манипулятора типа "мышь", отмечая необходимые точки на графике, и используя отображаемые координаты точек;

3) Скопировав данные из сторонней программы в буфер обмена и вставив их в таблицу данных;

4) Открыв текстовый (.txt) или MS Excel (.xls) файл с ранее сохранёнными данными либо файл, созданный в текстовом редакторе или программой MS Excel.

При импорте данных десятичный разделитель – точка либо запятая.

5) Импортировав данные из рабочего листа MS Excel с помощью кнопки [image] , при этом данные, расположенные в 2 ряда или в 2 столбца, должны быть выделены;

после построения тренда, он передаётся в этот же лист с помощью кнопки [image] .

6) Открыв файл проекта (.prj) , сохранённый ранее из окна работы с проектами.

Параметры построения тренда, выбрать которые можно, нажав кнопку главного меню "Параметры", во многом определяют время расчета. Рекомендуется начинать с небольших значений таких параметров, как "Относительная погрешность определения переменных" (по умолчанию 0.01), "Максимальное количество итераций" (по умолчанию 500), "Максимальное количество циклов" (по умолчанию 1000). Если результат Вас не удовлетворит, выбирайте параметры так, как Вам требуется, но будьте готовы к ожиданию построения тренда.

Если вычисления длятся долго, то в появившемся окне Вы сможете прервать расчет:

Для построения тренда нужно нажать на кнопку "Пуск" [image] , выбрав предварительно тип тренда и параметры его построения.

В режиме построения регрессии ПС СПС ориентированный, программа определяет оптимальный тип тренда , исходя из относительной погрешности исходных данных [image] .

Для её ввода следует нажать на клавишу [image] и в появившемся окне ввести для всех точек разную или одинаковую [image] . Полученная формула тренда будет наиболее достоверно (для пяти типов тренда – трёх типов трендов ПС СПС, линейного и степенного) соответствовать закономерности изменения исходных данных.

При двойном клике мышкой по графику в окне построения трендов открывается окно работы с проектами, при этом все построенные тренды с их атрибутами передаются в это новое окно. Все графики одного проекта будут иметь одинаковые размеры в пикселях, выбранные Вами произвольно. Это способствует единообразию при оформлении документов.

Кнопки окна работы с проектами описаны в разделе Интерфейс программы.


Печать и сохранение результатов

Печать графика тренда производится при выборе пункта меню "Печать графика" или при нажатии кнопки [image] в окне построения трендов, либо при нажатии кнопки [image] в окне для графиков.

Исходные данные можно сохранять в текстовом (.txt) или табличном (.xls) формате (см. пункт меню Сохранить данные в окне построения трендов).

Сохранить график тренда можно, выбрав пункт меню "Сохранить график" в окне построения трендов, при этом изображение будет сохранено в растровый файл (.bmp) размером 1018x372 пикселей при нормальном виде окна. При максимизированном окне размер изображения в файле будет зависеть от разрешения экрана.

В окне работы с проектами для сохранения графика тренда в bmp-файл служит кнопка [image] , при этом размер изображения в файле зависит от произвольно (от 400х300 пикселей до максимума, в зависимости от разрешения экрана) изменяемого размера окна работы с проектами. Поэтому получаемое изображение может иметь и альбомный, и портретный формат, либо вообще тот, который потребуется.

Можно скопировать график тренда в буфер обмена для последующей вставки в стороннюю программу, выбрав пункт меню "Копировать график в буфер обмена", либо при нажатии кнопки [image] в окне построения трендов.

Сохранить формулу тренда в символьном или графическом формате можно через буфер обмена, выбрав пункт меню "Копировать текстовую формулу тренда в буфер обмена" либо пункт меню " Копировать графическую формулу тренда в буфер обмена " соответственно.

Исходные и конечные данные с хранением заданного размера графиков и их оформления можно сохранять в виде файлов проектов (.prj) из окна работы с проектами, нажав кнопку [image] .

Экспорт в MS Excel

При выборе пункта меню "Экспорт в MS Excel" открывается новый экземляр программы Microsoft Excel, и в новом листе новой книги электронной таблицы будет нарисован тренд, проведённый программой.

Если данные были импортированы из рабочего листа MS Excel с помощью кнопки [image] , то после построения тренда, график и формула передаются в этот же лист MS Excel с помощью кнопки [image] .


Примеры построения уравнений регрессии, трендов

· Уравнения вида ПС СПС
· Уравнения вида ПП СК
· Уравнения вида ППЛС СК
· Уравнения вида НР СК
· Уравнения вида ППНР СК
· Уравнения вида ПАР СП
· Уравнения вида ПКС СП
· Уравнения вида ПSin
· Уравнения вида ПАSin
· Уравнения вида ППSin
· Уравнения вида ППАSin


Уравнения вида ПС СПС

Пример 1. Заданы некоторые значения аргумента Xi и зависимые от него случайные значения величины Yi (см. таблицу 2). Предполагая, что искомая регрессия Y обусловлена аддитивным влиянием одного фактора, отображаемого степенной функцией, выберем соответствующий тип уравнения А-Х(μ). В опциях задаваемых параметров выберем: число десятичных знаков после запятой в формуле уравнения - 4; относительная погрешность определения показателей степени – 0,001. Математическая формула и график уравнения регрессии, рассчитанные программой, представлены на рисунке 1.

Пример 2. В таблице 3 заданы некоторые значения аргумента Xi и зависимые от него случайные значения величины Yi. Положим, что искомая регрессия Y формируется под влиянием двух факторов, описываемых степенными функциями, аддитивно взаимодействующими на интервалах вогнутости и выпуклости линии тренда. Выберем соответствующий тип уравнения регрессии А-Х(μ1, μ2). В опциях его параметров выберем: число десятичных знаков после запятой в формуле уравнения - 4; относительная погрешность определения показателей степени – 0,001. Математическая формула и график уравнения, рассчитанные программой, представлены на рисунке 2.

Пример 3. Для построения уравнения регрессии в таблице 4 заданы значения аргумента Xi и зависимые от него случайные значения величины Yi. Положим, что факторы, влияющие на формирование уравнения регрессии, взаимодействуют аддитивно и выражаются степенными функциями. В опциях параметров уравнения выберем: число десятичных знаков после запятой в его формуле - 4; относительная погрешность определения показателей степени – 0,001. Зададим расчет параметров уравнения в опции «ориентированный» в двух следующих случаях.

В первом случае зададим одинаковую для всех узловых точек относительную погрешность исходных значений Yi равной 0,018. Тогда получим коэффициент заданной детерминации Rз2 = 0,9679. После запуска программа автоматически определяет тип ориентированного на погрешность уравнения А-Х(μ), отображающего влияние лишь одного фактора в виде степенной функции. Математическая формула и график уравнения, рассчитанные программой, представлены на рисунке 3а.

Во втором случае зададим также одинаковую для всех узловых точек, но уменьшенную относительную погрешность исходных значений Yi , равную 0,010. Тогда получим коэффициент заданной детерминации Rз2 = 0,9901. После запуска программа автоматически определяет тип ориентированного на погрешность другого уравнения А-Х(μ1,μ2). В нем степенными функциями отражено аддитивное влияние двух факторов. Математическая формула и график уравнения, рассчитанные программой в этом случае, представлены на рисунке 3б.

Пример 4. В таблице 5 заданы значения аргумента Xi и определенные с высокой точностью соответствующие значения зависимой величины Yi. В опциях параметров искомого уравнения регрессии выберем: число десятичных знаков после запятой в его формуле - 6; относительная погрешность определения показателей степени – 0,0001. Зададим определение уравнения в опции «ориентированный», записав в появившуюся таблицу условие, что относительная погрешность исходных значений зависимой величины равна нулю. При этом получим Rз2 = 1. После запуска программа автоматически определяет тип ориентированного на погрешность уравнения А-Х(μ1,μ2,μ3), в котором тремя степенными функциями аддитивно учтено влияние трех факторов. Математическая формула и график уравнения, рассчитанные программой, представлены на рисунке 4.


Уравнения вида ПП СК

Пример 5. Заданы значения аргумента Xi и зависимые от него случайные значения величины Yi в некоторых точках (см. таблицу 6). Предполагая, что регрессионная зависимость Y от X обусловлена аддитивным влиянием одного фактора, выраженного показательной функцией, выберем тип искомого уравнения А-Х(β). В опциях его параметров выберем: основание показательной функции - число e; число десятичных знаков после запятой в формуле уравнения - 5; относительная погрешность определения коэффициента в показателе степени – 0,0001. Построим уравнение в двух следующих режимах.

В первом режиме точка пересечения линии регрессии с вертикальной осью координат Y не задана. Соответствующая математическая формула уравнения Y1 и его график (сплошная линия), рассчитанные программой, представлены на рисунке 5.

Во втором режиме зададим пересечение линии регрессии с вертикальной осью координат в точке Y = 1. Соответствующая этому дополнительному условию математическая формула уравнения Y2 и его график (пунктирная линия), рассчитанные программой, представлены также на рисунке 5.

Пример 6. В таблице 7 заданы значения аргумента Xi и зависимые от него случайные значения величины Yi . Предполагая, что регрессия Y обусловлена аддитивным влиянием двух факторов, отображенных показательными функциями, выберем тип искомого уравнения А-Х(β1, β2). В опциях его параметров выберем: основание показательных функций - число e ; число десятичных знаков после запятой в формуле - 5; относительная погрешность определения коэффициентов в показателях степени – 0,0001.

Математическая формула и график уравнения, рассчитанные программой, представлены на рисунке 6.


Уравнения вида ППЛС СК

Пример 7. Заданы некоторые значения аргумента Xi и зависимые от него случайные значения величины Yi (см. таблицу 8).

Известно, что регрессия Y формируется под влиянием аддитивно действующих двух факторов. Один из них на интервале крутого возрастания Y отображается показательной функцией, а другой фактор наклонной асимптоты, к которой приближается линия регрессии при возрастании аргумента, отображается линейной функцией. Выберем тип соответствующего уравнения А-Х(β, μ=1). В опциях его параметров выберем: основание показательной функции - число e ; число десятичных знаков после запятой в формуле - 6; относительная погрешность определения коэффициента в показателе степени – 0,0001. Построим уравнение в двух следующих режимах.

В первом режиме точка пересечения линии регрессии с вертикальной осью координат Y не задана. Соответствующая математическая формула уравнения Y1 и его график (сплошная линия), рассчитанные программой, представлены на рисунке 7.

Во втором режиме зададим пересечение линии регрессии с вертикальной осью в начале координат, т.е. в точке Х=0, Y=0. Соответствующая этому дополнительному условию математическая формула уравнения Y2 и его график (пунктирная линия), рассчитанные программой, представлены также на рисунке 7.


Уравнения вида НР СК

Пример 8. В таблицах 9 и 10 заданы две выборки некоторых значений аргумента Xi и соответствующих им распределений случайных значений величины Yi.

Полагая, что регрессия в каждой выборке описывается нормальным распределением, назначим соответствующий тип уравнения М-Х(, σ). В опциях параметров выберем: число десятичных знаков после запятой в формуле уравнения - 4; относительная погрешность определения параметров – 0,001. Исходные данные, формулы и графики построенных уравнений приведены на рисунке 8.

Из уравнения Y1, построенного по таблице 9, определяются центр распределения [image] =-4,6665 и среднее квадратичное отклонение σ = 1,0957. Из уравнения Y2, построенного по таблице 10, так же определяются [image] =2,7225 и σ = 0,2861.


Уравнения вида ППНР СК

Пример 9. Для построения двух уравнений регрессии, трендов в таблицах 11 и 12 заданы соответствующие значения величин Xi и Yi.

Положим, что регрессии обусловлены аддитивным влиянием двух факторов. Один из них проявляется на широком интервале оси абсцисс и отображается показательной функцией. Другой фактор локального аддитивного действия отображается функцией нормального распределения. Выберем тип соответствующего уравнения АМ-Х(β, , σ). В опциях его параметров выберем: число десятичных знаков после запятой в формулах уравнений - 4; относительная погрешность определения коэффициента в показателе степени – 0,01.

Уравнение регрессии, построенное по данным таблицы 11, показано на рисунке 9а. Обнаруженное регрессией положительное нормальное распределение локализовано вокруг его центра [image] =6,3348 и характеризуется среднеквадратичным отклонением σ = 1,9943. Уравнение, построенное по данным таблицы 12, показано на рисунке 9б. Здесь в узкой локальной области обнаружено регрессией отрицательное нормальное распределение с центром [image] =185,461 и среднеквадратичным отклонением σ = 7,3416.


Уравнения вида ПАР СП

Пример 10. В таблице 13 заданы некоторые значения аргумента Xi и соответствующие им распределение случайных значений величины Yi .

Видно, что распределение Yi обладает правосторонней асимметрией. Известно также, что линия регрессии должна пересекать ось ординат при значении X=0. Полагая, что регрессия обусловлена мультипликативно взаимодействующими факторами, выраженными степенной и показательной функциями, выберем соответствующий тип уравнения М-X(а, μ). В опциях параметров выберем: число десятичных знаков после запятой в его формуле - 5; относительная погрешность определения параметров – 0,001. Построим уравнение в двух следующих режимах.

В первом режиме точка пересечения линии регрессии с вертикальной осью Y не задана. В результате построения получим уравнение регрессии Y1, формула и график которого в виде сплошной линии изображены на рисунке 10. Во втором режиме в опции «Параметры» зададим пересечение линии регрессии с вертикальной осью Y в точке X=0, Y =0. Тогда получим другое уравнение регрессии Y2, формула которого и график в виде пунктира также изображены на рисунке 10.

Пример 11. В таблицах 14 и 15 заданы две выборки некоторых значений аргумента Xi и соответствующих им распределений случайных значений величины Y i.

Распределение Yi, приведенное в таблице 14, обладает правосторонней асимметрией. Точки, находящиеся на крутом склоне распределения, существенно удалены по оси абсцисс от ее начала. Распределение Yi , приведенное в таблице 15, обладает левосторонней асимметрией. Поэтому, полагая, что регрессия обусловлена мультипликативно взаимодействующими факторами, выраженными сдвинутыми степенной и показательной функциями, выберем соответствующие типы смещенных уравнений М-X( а, μ, x > xo) и М-X( а, μ, x < xo). Установим: количество учтенных в расчетах десятичных разрядов 4; относительная погрешность расчетов 0,001. Входные данные, формулы и графики построенных уравнений регрессии показаны на рисунке 11.

Уравнение с правосторонней асимметрией, рассчитанное по данным таблицы 14, отображено на фрагменте а. Область его определения х >149,73. Уравнение с левосторонней асимметрией, рассчитанное по данным таблицы 15 в двух режимах, показаны на фрагменте б.

В первом режиме точка пересечения линии регрессии с вертикальной осью Y не задана. Получено уравнение Y1 с областью определения 0< х<0,7713 .

Во втором режиме такая точка с координатами (0, 0) задана. Получено уравнение Y2 с областью определения 0< х<0,7737 .

Пример 12. В таблицах 16 и 17 заданы две выборки некоторых значений аргумента Xi и соответствующих им распределений случайных значений величины Yi.

Распределение Yi, приведенное в таблице 16, смещено по оси абсцисс, обладает правосторонней асимметрией и предположительно содержит два максимума. Распределение Yi , приведенное в таблице 17, обладает левосторонней асимметрией и так же содержит два максимума. Полагая, что регрессия обусловлена аддитивно и мультипликативно взаимодействующими факторами, выраженными степенными и показательными функциями, выберем соответствующие типы смещенных уравнений АМ-X(а1, а2, μ1, μ2, х> х01, х > х02), АМ-X(а1, а2, μ1, μ2, х < х01, х < х02). Установим: количество учтенных в расчетах десятичных разрядов 4; относительная погрешность расчетов 0,001. Входные данные, формулы и графики построенных уравнений регрессии показаны на рисунке 12.

Уравнение с правосторонней асимметрией и его график, рассчитанные по данным таблицы 16, показаны на фрагменте а. Область его определения х >0,068. Уравнение с левосторонней асимметрией и его график, рассчитанные по данным таблицы 17 в двух режимах, показаны на фрагменте б. В первом режиме точка пересечения линии регрессии с вертикальной осью Y не задана. Получено уравнение Y1 с областью определения 0< х<70,1634. Во втором режиме такая точка с координатами (0, 0) задана. Получено уравнение Y2 с областью определения 0< х <71,6902.

Пример 13. В таблице 18 заданы значения аргумента Xi и соответствующее им распределение случайных значений величины Yi.

Распределение значений Yi удалено по оси абсцисс от начала координат, характеризуются крутым подъемом слева, двумя максимумами и крутым спуском справа. Предположим, что такое распределение обусловлено влиянием аддитивно взаимодействующих факторов, выраженных двумя встречно направленными асимметричными функциями, каждая из которых представлена комбинацией степенных и показательных функций. Выберем соответствующий тип смещенного уравнения АМ-X(а1, а2, μ1, μ2, х01< х < х02). В опциях параметров выберем: число десятичных знаков после запятой в его формуле - 4; относительная погрешность определения параметров – 0,001. Заданные точки, а также формула уравнения регрессии и его график, рассчитанные и построенные программой, представлены на рисунке 13. Область определения полученного уравнения 6,9795 < х < 15,049.


Уравнения вида ПКС СП

Пример 14. По экспериментальным точкам с координатами Xi и Yi, приведенными в таблице 19, надо построить уравнение регрессии, описывающее переходный процесс от некоторого начального значения зависимой величины Y1 до ее конечного значения Y2.

Предположим, что регрессия обусловлена аддитивным влиянием фактора, представленного в виде квазиступенчатой функции, сопрягающей значения Y1 в начале и Y2 в конце перехода. Таким образом, графики начального (до перехода) и конечного (после перехода) участков квазиступенчатой функции должны выражаться горизонтальными прямыми линиями. Выберем тип искомого уравнения А-X(х0, β)Г. В опциях его параметров установим: число десятичных знаков после запятой в формуле уравнения - 5; относительная погрешность определения параметров – 0,001. Заданные точки, уравнение регрессии и его график, рассчитанные программой, показаны на рисунке 14. Из формулы уравнения следует, что квазиступенчатая функция асимптотически сопрягается в начале и в конце перехода с соответствующими значениями Y1=0,01169 и Y2=0,99135. Значение аргумента в центре перехода между ними составляет х0=17,02007.

Пример 15. По заданным значениям Xi и Yi, приведенным в таблице 20, требуется провести уравнение регрессии, описывающее переходный процесс от начальной линейной функции Y1 до конечной линейной функции Y2. Известно, что функция Y2 должна иметь угловой коэффициент такой же, как у функции Y1.

Предположим, что регрессия обусловлена аддитивным влиянием факторов, представленных в виде квазиступенчатой функции, сопрягающей линейную функцию Y1, действующую в начале перехода, со сдвинутым по оси ординат ее аналогом Y2, действующим в конце перехода. Таким образом, графики начального (до перехода) и конечного (после перехода) участков квазиступенчатой функции должны выражаться наклонными и параллельными прямыми линиями. Выберем тип искомого уравнения А-X(х0, β)П. В опциях его параметров установим: число десятичных знаков после запятой в формуле уравнения - 5; относительная погрешность определения параметров – 0,001. Заданные точки, уравнение регрессии и его график, рассчитанные программой, показаны на рисунке 15.

Из формулы уравнения следует, что квазиступенчатая функция на ее начальном и конечном участках асимптотически сопрягается с соответствующими линейными уравнениями

Y1= -0,47651•х + 90,81787;

Y2= -0,47651•х - 101,1191.

Значение аргумента, в центре перехода между ними, составляет х0= -0,03746.

Пример 16. По заданным значениям Xi и Yi, приведенным в таблице 21, требуется провести уравнение регрессии, описывающее переходный процесс от начальной линейной функции Y1 до конечной линейной функции Y2.

Предположим, что регрессия обусловлена аддитивным влиянием факторов, представленных в виде квазиступенчатой функции, сопрягающей линейную функцию Y1, действующую в начале перехода, с другой линейной функцией Y2, действующей в конце перехода. Таким образом, графики начального (до перехода) и конечного (после перехода) участков квазиступенчатой функции должны выражаться какими либо прямимыми линиями. Выберем тип искомого уравнения А-X(х0, β). В установочных опциях зададим: число десятичных знаков после запятой в формуле уравнения - 5; относительная погрешность определения его параметров – 0,001. Заданные точки, уравнение регрессии и его график, рассчитанные программой, показаны на рисунке 16. Из формулы уравнения следует, что квазиступенчатая функция на ее начальном и конечном участках асимптотически сопрягается с соответствующими линейными уравнениями

Y1= -0,53612•х – 9,00259;

Y2= 0,21625•х + 9,28661.

Значение аргумента, в центре перехода между ними, составляет х0= 2,52134.


Уравнения вида ПSin

Пример 17. В таблице 22 заданы некоторые значения аргумента Xi и зависимые от него случайные значения величины Yi. Предполагая, что искомая регрессия Y обусловлена аддитивным влиянием одного периодически действующего фактора, отображаемого функцией синуса, выберем соответствующий тип уравнения А-X(ω, φ). В опциях задаваемых параметров выберем: число десятичных знаков после запятой в формуле уравнения - 4; относительная погрешность определения частоты и фазы синуса – 0,001. Математическая формула и график уравнения регрессии, рассчитанные программой, представлены на рисунке 17.


Уравнения вида ПАSin

Пример 18. В таблице 23 заданы некоторые значения аргумента Xi и зависимые от него случайные значения величины Yi. Положим, что искомая регрессия Y описывает процесс колебаний, затухающих к постоянному уровню. Она формируется под влиянием двух мультипликативно взаимодействующих факторов. Фактор колебаний выражается функцией синуса, а фактор затухания его амплитуды - показательной функцией. Данным условиям соответствует уравнение регрессии типа АМ-X(ω, φ, βа). В опциях его параметров выберем: число десятичных знаков после запятой в формуле уравнения - 4; относительная погрешность определения функциональных параметров – 0,001. Математическая формула и график уравнения, рассчитанные программой, представлены на рисунке 18.


Уравнения вида ППSin

Пример 19. В таблице 24 заданы некоторые значения аргумента Xi и зависимые от него случайные значения величины Yi. Положим, что искомая регрессия Y формируется под влиянием аддитивно взаимодействующих двух факторов. Действие одного из них приводит к монотонному убыванию фона и описывается показательной функцией, а действие другого – к колебаниям около фона и описывается функцией синуса. Выберем соответствующий тип уравнения регрессии А-X(ω, φ, βп). В опциях его параметров выберем: число десятичных знаков после запятой в формуле уравнения - 4; относительная погрешность определения параметров функций – 0,001. Математическая формула и график уравнения, рассчитанные программой, представлены на рисунке 19.


Уравнения вида ППАSin

Пример 20. В таблице 25 заданы некоторые значения аргумента Xi и зависимые от него случайные значения величины Yi. Положим, что искомая регрессия Y описывает затухающие колебания вокруг переменного уровня, монотонно восходящего к стабильному состоянию. Она формируется под влиянием трех факторов. Аддитивное действие одного из них монотонно возрастающее, описывается показательной функцией, а мультипликативное действие двух других – периодическое, описывается синусом с уменьшающейся амплитудой. Выберем соответствующий тип уравнения регрессии АМ-X(ω, φ, βп , βа). В опциях его параметров выберем: число десятичных знаков после запятой в формуле уравнения - 4; относительная погрешность определения функциональных параметров – 0,001. Математическая формула и график уравнения, рассчитанные программой, представлены на рисунке 20.


Техническая поддержка

Для помощи в использовании программы обращайтесь:

ИГД УрО РАН, г.Екатеринбург, ул.Мамина-Сибиряка, 58, к.804

Тел. (343) 350-37-09

E-mail: antonov@igduran.ru , mikhail-66@mail.ru

Для приобретения полнофункциональной версии программы:

ИГД УрО РАН, г.Екатеринбург, ул.Мамина-Сибиряка, 58, к.404

Тел. (343) 350-21-86

Факс (343) 350-21-11

E-mail: direct@igduran.ru


Лицензионное соглашение

 Top Previous

В настоящем Лицензионном Соглашении с конечным пользователем, именуемом в дальнейшем "Соглашение", программа Уравнения нелинейной регрессии, тренды двумерные функционально-факторные с самоопределяющимися параметрами и повышенной достоверностью (Тренды ФСП-1) , включая без каких-либо ограничений любые названия, компьютерные коды, темы, названия объектов, концепции и относящиеся к ним рабочие методики, и все связанные с ней печатные материалы и диалоговая или электронная документация, а также все копии совокупно составляют определение "Программа".

1. СОБСТВЕННОСТЬ

Программа, все копии и неотделимые производные Программы и всех интеллектуальных прав собственности на Программу и любые такие копии и производные от них являются исключительной собственностью ИГД УрО РАН (регистр. номер 2011616230), чей юридический адрес г.Екатеринбург, ул.Мамина-Сибиряка, 58.

ИГД УрО РАН является владельцем всех прав на эту программу.

Программа защищена в соответствии с российскими законами об авторском праве, международными соглашениями авторского права и соглашениями и другими применимыми законами.

2. ПРЕДОСТАВЛЕНИЕ ЛИЦЕНЗИИ

Все случаи использования Программы подпадают под действие вышеназванного соглашения. Программа может использоваться только в течение срока его действия, и любое использование Программы или любой ее части, включая, без каких-либо ограничений, ее копирование или распространение помимо условий этого соглашения недвусмысленно запрещено.

Настоящим ИГД УрО РАН предоставляет Вам ограниченную, не-эксклюзивную лицензию ("Лицензия"), для установки и использования одной (1) копии Программы для вашего личного пользования только на одном компьютере. Запрещается установка Программы в сеть или иная ее установка более чем на одном компьютере.

Устанавливая Программу, Вы становитесь пользователем Лицензии и соглашаетесь выполнить соответствующие условия названного соглашения. Лицензия не подразумевает никаких прав на обладание полной Программой или любой ее частью.

3. ССЫЛКА ПРИ ИСПОЛЬЗОВАНИИ

Вы согласны с тем, что в случаях воспроизведения, опубликования, размещения, издания и (или) распространения Вами в литературе, в сети Интернет, в т. ч. в статьях, отчетах, журналах, книгах, сайтах, блогах, или в других официальных печатных, рукописных, Интернетных изданиях и документах, графиков, математических формул трендов, полученных с помощью Программы, или каких-либо ее характеристик, параметров, изображений файлов или других фрагментов Программы, Вы обязаны сопроводить перечисленные материалы следующей ссылкой:

Антонов В.А. Уравнения нелинейной регрессии, тренды двумерные функционально-факторные с самоопределяющимися параметрами и повышенной достоверностью (Тренды ФСП-1): программа для ЭВМ, РФ; регистр. номер 2011616230 / В.А. Антонов, М.В. Яковлев; ИГД УрО РАН.- Екатеринбург, 2011.

4. ОГРАНИЧЕНИЯ НА ИСПОЛЬЗОВАНИЕ

Вы не имеет права пользоваться программой иным способом, отличным от вышеназванного, и, в частности Вы не можете:

(а) полностью или частично, редактировать, копировать, фотокопировать, воспроизводить, переводить на другой язык или перепроектировать Программу, извлекать ее исходный код или изменять, демонтировать или декомпилировать, создавать любые производные изделия, основанные на Программе, за исключением случав, разрешенных действующим законодательством несмотря на это ограничение;

(б) удалять любые предупреждения и фирменные знаки из какой-либо части Программы без предварительного письменного согласия ИГД УрО РАН;

(в) извлекать или выделять какие-либо составные части Программы для использования на более, чем одном компьютере или использовать какие-либо подобные части на более чем одном компьютере;

(г) продавать, отдавать под залог или передавать какие-либо копии Программы (или любые ее части) какому-либо третьему лицу любым способом, а также давать напрокат или в субаренду третьему лицу без предварительного письменного согласия ИГД УрО РАН.